We’re in the process of upgrading all web servers in our server farm.  As part of the migration we're disabling TLS 1.0 now and will disable TLS 1.1 in the future.  


Browsers

All modern browsers support TLS 1.2. Here’s a page that shows support of TLS 1.2 by browser: https://caniuse.com/#feat=tls1-2


Here’s a link to an article about enabling TLS 1.2 in browsers (if its supported but not enabled):

https://knowledge.digicert.com/generalinformation/INFO3297.html


Custom Integrations

If your organization has developed custom integrations with our web services, please ensure that they support TLS 1.2.