The following How To's help you generate reports from your data in the Enterprise portal. Use these How To's to keep track of how well your organization is operating and meeting your customer's needs. View employee-related data at a glance, and schedule reports to be sent automatically to alert specific individuals when shifts are not being worked as scheduled.

Report How To's include the following:

Refer to the following How To's.


Using the Reports Home Page

When you click the Reports link, reports menu selections display. The Reports section allows you to view data across all locations, employees, scheduling, and time periods. There are easy-to-use report development windows as well as fixed reports.


Access Reports functions from:

  • Report menu toolbar

  • Sections link on the Reports home page

There are several ways to open existing reports. See:


Using the Reports Tab

Use the Reports > Reports tab drop-down list to display reports you have created in your account. You can view reports under Organization, Employee, Scheduling, and Time & Attendance. You can also access the reports you designated as Favorites.


To display Reports:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Reports.
    Reports List drop-down menu displays. Categories include: Favorites, Organization, Employee, Scheduling, and Time & Attendance.

  3. Scroll down the list of categories and move your cursor to the right. Choose the report to access from the category sub-menu list.
    The highlighted report displays.


Using the Reports List

Use the Reports > List section to access fixed reports, designed reports, charts created, and packages created in the Enterprise portal.


To view Reports:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click List.
    Explanation: Reports are listed under the data-source categories: Organization, Employee, Scheduling, and Time.

  3. Select one of the following radio button list options to filter the list. Each is explained as follows.

    Option

    Displays...

    All

    All reports available in your Enterprise portal. This list includes those that are pre-loaded as well as those you have created. The icon next to the report shows if it is a designed report (letter page) or a fixed report (square with a dot in center), chart, or package.

    Packages

    Report Packages you created using a report design, filter, and style. You may also have scheduled the report to generate on a timed basis and may have designated subscribers to automatically receive report results.

    Designs

    Reports that were ScheduleSource designed and pre-loaded or custom reports you designed for your organization. Design options include group / sort properties and specific column properties. You may also select filtering mechanisms, tally functions, and display features. You can make a copy of any of these reports and then edit the copy to create a new report.

    Charts

    Charts that you designed for your organization to display summary data graphically. Chart types include: Bar, Column, Line, and Pie. You select the data source and values for both the X-Series and Y-Series. Options include showing a legend, type of display, and if shared with locations.

    Fixed

    Fixed reports that have been created by ScheduleSource and pre-loaded: Schedule Headcounts and Schedule Month View. You cannot edit or copy these reports. You can apply filtering, date ranges, grouping, and styles. Group data differently and specify different intervals to meet your organization's reporting needs.


  4. Click on the report you would like to view or edit.
    The page refreshes and the report displays.

  5. To edit the report, see Editing a Report.

  6. To print the report, see Printing a Report.

  7. To change the report format, see Creating Report Styles.


Viewing a Report

Use the Reports > Reports tab, the Reports > List tab, or the Recent tab to display a report you have created in your account. You can also view reports from any of the report development tabs: Designs, Charts, Filters, Styles, and Packages.


To view a Report:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Reports, List, or Recent and select the report you would like to view.
    Report displays.

  3. To edit the report, click Edit.

  4. To download the report, click Download and select the format: Pdf, Csv, Tab, or XML.

  5. To designate this report as a Favorite, click the gold star indicating Favorites.

  6. To display this report with data from the past or future, click the green back or forward arrow.

  7. To change the display style, click the Style tab and select the new style in the Select Style window.

  8. To change the data, click the Filter tab and select the filter from the Adjust Filter window and enter Dates and Data information. You may also delete a current filter in the window.

  9. To change the amount of time the report covers, select Range and use the drop-down list to select one of the following: Day, Week, Month, Quarter, or Year.
    Note: When you view the report, this is the time period that displays until you select a different Range.


Editing a Report

Once you have created a report, it is easy to edit it. The following procedures involve editing the different report sections. They include:

  • Editing Settings

  • Editing Group/Sort

  • Managing Columns for Data Displayed

Refer to the following How To's.


To edit Settings:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Reports or List and select the report you would like to edit.
    Report displays.

  3. Click Edit in the reports toolbar.
    The report displays in an edit mode.
    Note: You can toggle between View and Edit by clicking the View button or the Edit button on the reports toolbar. This lets you quickly see the results of your edits to a report as you make changes.

  4. Under Settings, rename the report by typing the new name and click Save.

  5. To share it with a location, select the check box for: Shared with Locations and click Save. When the Enterprise report displays in the Location portal, it will only show data related to that location.
    Explanation: If you share with locations, a report is added to the Reports Section for all locations. Users in the Location portal can view the report, but they cannot edit it or delete it. However, they can copy it and edit or delete that copy. Changes made to a copy of the report in one location do not affect the report in other locations nor do they affect the original Enterprise portal report.

  6. To copy the report, click Copy.
    A copy is added to your left menu list with the name of the report and (copy) appended.
    Hint: This is very useful if you want to make a new report with some additional information in it.

  7. To delete a report, see Deleting a Report.

To edit Group/Sort:

  1. To add a Group Header to the Report, click Add.
    Add Group/Sort window displays.

  2. Select the column you want to Group by and click Add.

  3. Select the check box to the left of that column name to display it in the report. This adds a Group Header using that column data.

  4. To change the name of the column, click on the name to display the Properties window.

  5. Enter the name to display in the report in the Name field and click Save.
    New Column name displays under Group/Sort.

  6. To add a Sort order to the report, click Add.
    Add Group/Sort window displays.

  7. Select the column you want to Sort by and click Add.

  8. To change the name of the column, click on the name to display the Properties window.

  9. Enter the name to display in the report in the Name field.

  10. From the Sort drop-down list, select either Ascending or Descending.

  11. Click Save.

To manage Columns for data display:

  1. To add columns, click Add.
    Add Column window displays.

  2. Select one or more columns using the drop-down list.
    Remember: You can select multiple columns by holding down the CTRL key as you click on each column name.

  3. To delete a column, click on the column name to highlight it. Click the X
    Note: When you hover over the X, it displays delete.

  4. To reorder columns, click on the column name you want to move to highlight it. Click the up or down arrows to change the order of this column.

  5. To change the Properties of a column, double-click on the column.
    Properties window displays.

  6. Apply a Filter, set Tally Functions, and change the Display.

  7. Click Save.

  8. To hide a column, clear the check the box to the left of the column name.
    Report displays without this column information.

  9. To display the hidden column again, select the check box to the left of the column name.
    Report displays with this column information.


Creating Report Filters

Use the Filters link in the Reports section of the Enterprise portal to create report filters. You can slice and dice your data into many different views. For information on using formula columns, refer to Column Formula Quick Reference.

To create report Filters:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Filters.
    Charts window displays.

  3. Click Add or select an existing report Filter.
    Filters window displays.
    Note: If you selected an existing Filter, the values display in the expanded Filters window.

  4. Type the Name and click Save.
    Note: If you selected an existing Filter, you can click Save As and use the existing parameters to build a new Filter.

  5. Enter the date and date range filter information. You can select days, weeks, months, quarters, and years.

  6. To add fields, under New condition, use the drop-down list to select the Field, i.e., Employees.
    Drop-down list expands to include the records in that category.

  7. Select each record.
    Note: Use Click + CTRL+ Click or Click + Shift Click to highlight multiple records. You can also use the Find button to search for a specific record.

  8. Click the right arrow to move the records into the Value column.

  9. To add conditions, click the Add Condition button

  10. Click Save.
    Values display under Values. You can click Remove to delete them and select other values.

  11. To replace the current filter with this, click the Make Current button.

  12. To delete the filter and start over, click Delete.


Printing a Report

Use the Print link in the Reports section of the Enterprise portal to print reports. You can print a report that displays in the right pane at any time. Use the Reports tab or the List tab to display a report. See:

Refer to the following How To.


To print a Report:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Reports or List and select the report you would like to print.
    Report displays.

  3. Click Reports > Print.
    Printer screen or browser print window displays. Use preview or browser commands to resize and format the page.

  4. Click Print.


Creating Report Designs

Use the Designs link in the Reports section of the Enterprise portal to create report designs. You can create reports for many different sections in the Enterprise portal, and you can include the specific fields that help you manage your organization. Use the statistics you have available at your fingertips to ensure that you are optimizing the scheduling and use of your employees against your organization's management needs. For a detailed explanation of using this window, see Understanding Report Designs.

You can design two types of reports: List and Crosstab. Each type of report design has different steps and is addressed in the following How To's.


Designing a List Report

The following How To outlines the procedure you use to create a List report design.

To create a List report design:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Designs.
    Designs window displays.

  3. Click Add or select an existing report Design.
    Settings window displays.
    Note: If you selected an existing Design, the values display in the expanded Designs window.

  4. Type a report Name.

  5. Select the Source.

  6. Select the Type: List

  7. Select the check box to Share with Locations if this report is to be available in the Location portal.

  8. Click Save.
    Additional settings display.

  9. First, choose the columns for data you want to display. Under Columns, click Add.
    Add Column window displays.

  10. Select the field to add and click Add.
    Note: To select multiple fields, hold down the CTRL key while selecting the fields. Use the arrow keys to move fields up and down.

  11. Under Group / Sort, click Add.
    Add Group/Sort window displays list of available fields.

  12. Select the check box to the left of the field to display the field on a report or clear the check to hide the field when you view the report.

  13. To change the name of the column, click on the name to display the Properties window.

  14. Define field properties such as the Name, Filter, Tally Functions, and Display.

  15. Click Save.

  16. Next, add a Sort and/or Group header. Under Group / Sort, click Add.
    Add Group/Sort window displays list of available fields.

  17. Select the field to add and click Add.
    Note: To select multiple fields, hold down the CTRL key while selecting the fields. Use the arrow keys to move fields up and down.

  18. Select the check box to the left of the field to add a group header to the report.

  19. Use the up and down arrows to move the columns in the order you want them to be sorted.

  20. To set Properties, click on the field.
    It is highlighted and the Properties window displays.

  21. Define field properties such as the Name, Filter, Tally Functions, and Display.

  22. Click Save.

  23. To view the report, click View.
    Hint: Remember that you can include or exclude fields by selecting or clearing the check box to the left of the field. The report displays the fields you select.

  24. To delete a report Column, highlight the column name and click the X.

  25. To delete the report, see Deleting a Report.


Designing a Crosstab Report

The following How To outlines the procedure you use to create a Crosstab report design.


To create a Crosstab Report Design:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Designs.
    Designs window displays.

  3. Click Add or select an existing report Design.
    Settings window displays.
    Note: If you selected an existing Design, the values display in the expanded Designs window.

  4. Type a report Name.

  5. Select the Source.

  6. Select the Type: Crosstab

  7. Select the check box to Shared with Locations if this report is to be available in the Location portal.

  8. Click Save.
    Additional settings display.

  9. First, choose the columns for data you want to display. Under Columns, click Add.
    Add Column window displays.

  10. Select the field to add and click Add.
    Note: To select multiple fields, hold down the CTRL key while selecting the fields. Use the arrow keys to move fields up and down.

  11. Under Group / Sort, click Add.
    Add Group/Sort window displays list of available fields.

  12. Select the check box to the left of the field to display the field on a report or clear the check to hide the field when you view the report.

  13. To change the name of the column, click on the name to display the Properties window.

  14. Define field properties such as the Name, Filter, Tally Functions, and Display.

  15. Click Save.

  16. Next, add a Sort and/or Group header. Under Group / Sort, click Add.
    Add Group/Sort window displays list of available fields.

  17. Select the field to add and click Add.
    Note: To select multiple fields, hold down the CTRL key while selecting the fields. Use the arrow keys to move fields up and down.

  18. Select the check box to the left of the field to add a group header to the report.

  19. Use the up and down arrows to move the columns in the order you want them to be sorted.

  20. To set Properties, click on the field.
    It is highlighted and the Properties window displays.

  21. Define field properties such as the Name, Filter, Tally Functions, and Display.

  22. Click Save.

  23. Under Crosstab, click Edit.
    Crosstab Fields window displays.

  24. Select Label and Value fields and click Save.

  25. To set Properties for Label, click on Label to add a Label Name. Select Filter, String, and Display options.

  26. Click Save.

  27. To set Properties for Value, click on Value to add a Value Name. Select Filter, Tally Functions, and Display options.

  28. Click Save.

  29. Click Save.

  30. To view the report, click View.
    Hint: Remember that you can include or exclude fields by selecting or clearing the check box to the left of the field. The report displays the fields you select.

  31. To delete a report Column, highlight the column name and click the X.

  32. To delete the report, see Deleting a Report.


Creating Charts

Use the Charts link in the Reports section of the Enterprise portal to create a Chart report. You can select from several different types: Bar, Column, Line, and Pie charts.


To create a Chart:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Charts.
    Charts window displays.

  3. Click Add.

  4. Type a chart Name.
    Note: You can always edit the name.

  5. Select the data Source.
    Note: This cannot be changed.

  6. Select the Type of chart: Bar, Column, Line, or Pie
    Note: You can always edit the Type of chart and display the same data in a different chart. However, when you select a Pie chart, it can only have one X-Series column and one Y-Series column.

  7. Choose the Options. Select the check box to Show Legend, Show Values, and if unsorted or data displays in Ascending or Descending order.
    Note: You can always edit the Options.

  8. Select the check box to Shared with Locations if this report is to be available in the Location portal. Note that the Enterprise chart shared with a location will only show data related to that location.
    Explanation: If you share with locations, this chart is added to the Reports Section for all locations. Users in the Location portal can view the chart, but they cannot edit it or delete it. However, they can copy it and edit or delete that copy. Changes made to a copy of the chart in one location do not affect the chart in other locations nor do they affect the original Enterprise chart.

  9. Click Save.
    The Chart displays in the in the left menu in a folder automatically created under the data source you selected. In addition, the window expands to include selections for X-Series and Y-Series Properties.

  10. Click Add to choose the X-Series columns.
    Add X Series window displays.
    Note: These are the grouping fields for calculated data.

  11. Select data item to add and click Add.
    Data displays in X-Series window.

  12. To change the name of the column, click on the name to display the Properties window.

  13. Enter the name to display in the chart in the Name field and click Save.
    Note: If you have more than one column choice, you can select the check box to the left of the name to display it in the report. To hide that column, clear the check box. If this is a Pie Chart, you can only display one X-Series column.

  14. Click Add to choose Y-Series columns.
    Add Y-Series window displays.
    Note: This is the calculated data to display for each X-Series grouping.

  15. To change the name of the column, click on the name to display the Properties window.

  16. Enter the name to display in the chart in the Name field and click Save.
    Note: If you have more than one column choice, you can select the check box to the left of to the name to display it in the report. To hide that column data, clear the check box. If this is a Pie Chart, you can only display one Y-Series column.

  17. To view the chart, click View.
    Chart displays data using the chart type you selected.

  18. To change the amount of time the chart displays, select Range and use the drop-down list to select one of the following: Day, Week, Month, Quarter, or Year.
    Note: When you view the chart, this is the time period that displays until you select a different Range.

  19. To edit a chart, click the Edit button. See Editing a Report.
    Remember: You may display the chart using all of the different chart types. You may also copy the chart and edit the copy.

  20. To print a chart, see Printing a Report.

  21. To delete a chart, see Deleting a Report.


Creating Report Styles

Use the Styles link in the Reports section of the Enterprise portal to create report styles. View the Default style that is loaded and add new styles.

To create report Styles:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Styles.
    Styles window displays.

  3. Click Add.

  4. Type a Style Name and click Save.
    The window expands to include Settings, Report fonts, and Data Table design selections as well as an Example of how the report displays with the settings you select.

  5. Option for Shared. Select No or Yes. This designates whether or not the style is or is not available for use at the Location portal.

  6. Option for Paging. This specifies whether or there are page breaks if the report is printed. Select the check box if you want page breaks.

  7. Select Report Fonts. The three font boxes are for the various parts of the report: header, body, and footer.

  8. Select Header text attributes: size of font and whether bold or normal.

  9. Select Footer text attributes: size of font and whether bold or normal.

  10. Select Data Table information: Font size, Column Headers, Group Headers, and Table Cells. Use the color drop-down selection display to select specific colors. The code for your selection is entered in the text box to the left.

  11. Click Save.
    The Example displays your selections at the bottom of the window.


Creating Report Packages

Use the Reports > Packages section to build custom report packages. Use the Report Designs, Report Filters, and Report Styles you have created and put them together into a single report package.


To add a report Package:

  1. Click the Reports link on the top menu.

  2. On the toolbar, click Packages.
    Packages window displays.

  3. On the Packages window, type a Group name if you want to create a folder to put the package into. (Optional)

  4. Type a Name.

  5. Type a Description if desired. (Optional)

  6. Select a report Design from the drop-down list.

  7. Select a Filter from the drop-down list.

  8. Select a Style from the drop-down list.

  9. Click Save.

  10. Click the Add button next to Deliveries to schedule the report to run automatically and have an email sent to the subscribers you choose.

  11. On the Package Deliver window, to Schedule the report to run, make sure the Schedule tab is selected.

  12. Type a report Name and select the start and end dates.
    Note: If you do not enter an end date, the report will continue to run indefinitely.

  13. Select the Type: REPORT: ALWAYS send report or ALERT: Only send if containing data.

  14. Select the frequency the report should run: Daily, Weekly, Monthly, Yearly, or Times. Depending on the frequency selected, the Package Deliver refreshes. Enter the additional frequency information requested.

  15. Click Save.
    Package Delivery window refreshes and a Delete button is added to the Schedule Tab window.
    Note: You may return to this window at any time to delete the report package.

  16. Click on the Subscribers Tab.

  17. Select the scope and recipient. Click Add.
    Window refreshes and Report Package information displays the number of subscribers who will receive the package email, the schedule, and next delivery. If it is an alert, that is also noted.

  18. To disable a subscriber from receiving the email, select the check box under Select and click the Toggle Enabled button. The Yes turns to No in the Enabled column.

  19. To delete a recipient, select the check box under Select and click Delete.

  20. Close the window.
    Schedule and Subscriber information displays on Packages window under Deliveries.

  21. To add additional schedules and deliveries, click Add next to Deliveries.

  22. To add additional Report Packages, click Add next to Packages on the top of the window.

  23. To edit the report package, see Editing a Report.
    Note: You may copy the report package and edit it. However, the scheduling and subscriber information under Deliveries does not duplicate.

  24. To view the report package, see Viewing a Report.

  25. To print the report package, see Printing a Report.

  26. To delete the report package, see Deleting a Report.


Deleting a Report

Once you have created a report, it is easy to delete it. However, be aware that once it is deleted, you cannot retrieve the report.


To delete a report:

  1. Click the Reports link on the top menu.

  2. Select the report you would like to delete. See Using the Reports Tab or Using the Report List.

  3. Click Delete to delete the report.
    System prompts you to verify the delete.

  4. Yes or Cancel to confirm the delete or cancel the action.
    Caution: If you delete a report, it cannot be retrieved.